#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)(\b\w+\b)([ ]+\1\b)+"
Local $sString = "the little cat cat is in the hat hat hat, we like it." & @CRLF & _
"the little cat cat is in the hat hat hat, we like it." & @CRLF & _
"the little cat cat is in the hat hat hat, we like it." & @CRLF & _
"the little cat cat is in the hat hat hat, we like it." & @CRLF & _
"the the little cat cat is in the hat hat hat, we like it." & @CRLF & _
"the the the little cat cat2 is in the hat hat hat2, we like it." & @CRLF & _
"aa abb bc" & @CRLF & _
"ab bbc cd dc dc dc eg"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)