re = /^(?:\/api|\/apis\/(?P<GROUP>[^\/]+))\/(?P<VERSION>[^\/]+)(?:\/namespaces\/(?P<NAMESPACE>[^\/]+))?\/(?P<RESOURCETYPE>[^\/\n]+)(?:\/(?P<NAME>[^\/\n]+))?(?:\/(?P<SUBRESOURCE>[^\/\n]+))?$/m
str = '## Cluster-scoped resources
/api/v1/RESOURCETYPE
/api/v1/RESOURCETYPE/NAME
/apis/GROUP/VERSION/RESOURCETYPE
/apis/GROUP/VERSION/RESOURCETYPE/NAME
## Namespace-scoped resources:
/api/v1/namespaces/NAMESPACE/RESOURCETYPE
/api/v1/namespaces/NAMESPACE/RESOURCETYPE/NAME
/apis/GROUP/VERSION/namespaces/NAMESPACE/RESOURCETYPE
/apis/GROUP/VERSION/namespaces/NAMESPACE/RESOURCETYPE/NAME
## Cluster-scoped subresource:
/api/v1/RESOURCETYPE/NAME/SUBRESOURCE
/apis/GROUP/VERSION/RESOURCETYPE/NAME/SUBRESOURCE
## Namespace-scoped subresource
/api/v1/namespaces/NAMESPACE/RESOURCETYPE/NAME/SUBRESOURCE
/apis/GROUP/VERSION/namespaces/NAMESPACE/RESOURCETYPE/NAME/SUBRESOURCE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end