use strict;
my $str = '## Cluster-scoped resources
/api/v1/RESOURCETYPE
/api/v1/RESOURCETYPE/NAME
/apis/GROUP/VERSION/RESOURCETYPE
/apis/GROUP/VERSION/RESOURCETYPE/NAME
## Namespace-scoped resources:
/api/v1/namespaces/NAMESPACE/RESOURCETYPE
/api/v1/namespaces/NAMESPACE/RESOURCETYPE/NAME
/apis/GROUP/VERSION/namespaces/NAMESPACE/RESOURCETYPE
/apis/GROUP/VERSION/namespaces/NAMESPACE/RESOURCETYPE/NAME
## Cluster-scoped subresource:
/api/v1/RESOURCETYPE/NAME/SUBRESOURCE
/apis/GROUP/VERSION/RESOURCETYPE/NAME/SUBRESOURCE
## Namespace-scoped subresource
/api/v1/namespaces/NAMESPACE/RESOURCETYPE/NAME/SUBRESOURCE
/apis/GROUP/VERSION/namespaces/NAMESPACE/RESOURCETYPE/NAME/SUBRESOURCE';
my $regex = qr`^(?:/api|/apis/(?P<GROUP>[^/]+))/(?P<VERSION>[^/]+)(?:/namespaces/(?P<NAMESPACE>[^/]+))?/(?P<RESOURCETYPE>[^/\n]+)(?:/(?P<NAME>[^/\n]+))?(?:/(?P<SUBRESOURCE>[^/\n]+))?$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}