import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:/api|/apis/(?P<GROUP>[^/]+))/(?P<VERSION>[^/]+)(?:/namespaces/(?P<NAMESPACE>[^/]+))?/(?P<RESOURCETYPE>[^/\\n]+)(?:/(?P<NAME>[^/\\n]+))?(?:/(?P<SUBRESOURCE>[^/\\n]+))?$";
final String string = "## Cluster-scoped resources\n"
+ "/api/v1/RESOURCETYPE\n"
+ "/api/v1/RESOURCETYPE/NAME\n"
+ "/apis/GROUP/VERSION/RESOURCETYPE\n"
+ "/apis/GROUP/VERSION/RESOURCETYPE/NAME\n\n"
+ "## Namespace-scoped resources:\n"
+ "/api/v1/namespaces/NAMESPACE/RESOURCETYPE\n"
+ "/api/v1/namespaces/NAMESPACE/RESOURCETYPE/NAME\n"
+ "/apis/GROUP/VERSION/namespaces/NAMESPACE/RESOURCETYPE\n"
+ "/apis/GROUP/VERSION/namespaces/NAMESPACE/RESOURCETYPE/NAME\n\n"
+ "## Cluster-scoped subresource:\n"
+ "/api/v1/RESOURCETYPE/NAME/SUBRESOURCE\n"
+ "/apis/GROUP/VERSION/RESOURCETYPE/NAME/SUBRESOURCE\n\n"
+ "## Namespace-scoped subresource\n"
+ "/api/v1/namespaces/NAMESPACE/RESOURCETYPE/NAME/SUBRESOURCE\n"
+ "/apis/GROUP/VERSION/namespaces/NAMESPACE/RESOURCETYPE/NAME/SUBRESOURCE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}