re = /\W*(grade_membership|zip)\W*/m
str = 'Find the words "grade_membership" and "zip".'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end