$re = '/\W*(grade_membership|zip)\W*/m';
$str = 'Find the words "grade_membership" and "zip".';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);