re = /https?:\/\/(?:open\.)?spotify.com\/(user|episode|playlist|track)\/(?:spotify\/playlist\/)?(\w*)/m
str = 'https://open.spotify.com/user/spotify/playlist/37i9dQZF1DZ06evO2ZpGiQ?si=-6S0EBlURrao__YyIOW6bg
https://open.spotify.com/episode/0aib8d7Hi7N9Td6eVKliWC?si=8f846b406a844873
https://open.spotify.com/playlist/7Kk0KvfzcaX4QLtli1rIBK
https://open.spotify.com/track/6PEd4IINRYCvjDXfKxO0pE?si=8f3fae6b22d64006
https://open.spotify.com/playlist/7Kk0KvfzcaX4QLtli1rIBK?si=dde5fbdbe97c4cfc
https://spotify.com/user/spotify/playlist/37i9dQZF1DZ06evO2ZpGiQ?si=-6S0EBlURrao__YyIOW6bg
https://spotify.com/episode/0aib8d7Hi7N9Td6eVKliWC?si=8f846b406a844873
https://spotify.com/playlist/7Kk0KvfzcaX4QLtli1rIBK
https://spotify.com/track/6PEd4IINRYCvjDXfKxO0pE?si=8f3fae6b22d64006
https://spotify.com/playlist/7Kk0KvfzcaX4QLtli1rIBK?si=dde5fbdbe97c4cfc
spotify:user:spotify:playlist:37i9dQZF1DZ06evO2ZpGiQ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end