import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/(?:open\\.)?spotify.com\\/(user|episode|playlist|track)\\/(?:spotify\\/playlist\\/)?(\\w*)";
final String string = "https://open.spotify.com/user/spotify/playlist/37i9dQZF1DZ06evO2ZpGiQ?si=-6S0EBlURrao__YyIOW6bg\n\n"
+ "https://open.spotify.com/episode/0aib8d7Hi7N9Td6eVKliWC?si=8f846b406a844873\n"
+ "https://open.spotify.com/playlist/7Kk0KvfzcaX4QLtli1rIBK\n"
+ "https://open.spotify.com/track/6PEd4IINRYCvjDXfKxO0pE?si=8f3fae6b22d64006\n"
+ "https://open.spotify.com/playlist/7Kk0KvfzcaX4QLtli1rIBK?si=dde5fbdbe97c4cfc\n\n\n\n"
+ "https://spotify.com/user/spotify/playlist/37i9dQZF1DZ06evO2ZpGiQ?si=-6S0EBlURrao__YyIOW6bg\n\n"
+ "https://spotify.com/episode/0aib8d7Hi7N9Td6eVKliWC?si=8f846b406a844873\n"
+ "https://spotify.com/playlist/7Kk0KvfzcaX4QLtli1rIBK \n"
+ "https://spotify.com/track/6PEd4IINRYCvjDXfKxO0pE?si=8f3fae6b22d64006\n"
+ "https://spotify.com/playlist/7Kk0KvfzcaX4QLtli1rIBK?si=dde5fbdbe97c4cfc\n\n\n"
+ "spotify:user:spotify:playlist:37i9dQZF1DZ06evO2ZpGiQ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}