const regex = /https?:\/\/(?:open\.)?spotify.com\/(user|episode|playlist|track)\/(?:spotify\/playlist\/)?(\w*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/(?:open\\.)?spotify.com\\\/(user|episode|playlist|track)\\\/(?:spotify\\\/playlist\\\/)?(\\w*)', 'gm')
const str = `https://open.spotify.com/user/spotify/playlist/37i9dQZF1DZ06evO2ZpGiQ?si=-6S0EBlURrao__YyIOW6bg
https://open.spotify.com/episode/0aib8d7Hi7N9Td6eVKliWC?si=8f846b406a844873
https://open.spotify.com/playlist/7Kk0KvfzcaX4QLtli1rIBK
https://open.spotify.com/track/6PEd4IINRYCvjDXfKxO0pE?si=8f3fae6b22d64006
https://open.spotify.com/playlist/7Kk0KvfzcaX4QLtli1rIBK?si=dde5fbdbe97c4cfc
https://spotify.com/user/spotify/playlist/37i9dQZF1DZ06evO2ZpGiQ?si=-6S0EBlURrao__YyIOW6bg
https://spotify.com/episode/0aib8d7Hi7N9Td6eVKliWC?si=8f846b406a844873
https://spotify.com/playlist/7Kk0KvfzcaX4QLtli1rIBK
https://spotify.com/track/6PEd4IINRYCvjDXfKxO0pE?si=8f3fae6b22d64006
https://spotify.com/playlist/7Kk0KvfzcaX4QLtli1rIBK?si=dde5fbdbe97c4cfc
spotify:user:spotify:playlist:37i9dQZF1DZ06evO2ZpGiQ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}