re = /^\s+|\s+$|(\s)\s+/m
str = ' esto es algo que tiene muchos espacios al pedo '
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result