$re = '/^\s+|\s+$|(\s)\s+/m';
$str = ' esto es algo que tiene muchos espacios al pedo ';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;