package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s+|\s+$|(\s)\s+`)
var str = ` esto es algo que tiene muchos espacios al pedo `
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}