re = /^[a-zA-Z0-9@\-\.]*$/m
str = 't3st
t#st
p@ssw0rd
t3sting@@@@akldsxfkshgkjaehfk
p23549$adk
dskalf
adv-admin
adv$-admin
eped360@gmail...comhelloco
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end