using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9@\-\.]*$";
string input = @"t3st
t#st
p@ssw0rd
t3sting@@@@akldsxfkshgkjaehfk
p23549$adk
dskalf
adv-admin
adv$-admin
eped360@gmail...comhelloco
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}