import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9@\\-\\.]*$";
final String string = "t3st\n"
+ "t#st\n"
+ "p@ssw0rd\n"
+ "t3sting@@@@akldsxfkshgkjaehfk\n"
+ "p23549$adk\n"
+ "dskalf\n"
+ "adv-admin\n"
+ "adv$-admin\n"
+ "eped360@gmail...comhelloco\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}