re = /:([a-zA-Z]+)?/
str = '[ child : parent ]
[anotherchild:parentA]
[somechild : parentB]
[ anychild:parent ]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end