package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:([a-zA-Z]+)?`)
var str = `[ child : parent ]
[anotherchild:parentA]
[somechild : parentB]
[ anychild:parent ]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}