#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ":([a-zA-Z]+)?"
Local $sString = "[ child : parent ]" & @CRLF & _
"" & @CRLF & _
"[anotherchild:parentA]" & @CRLF & _
"" & @CRLF & _
"[somechild : parentB]" & @CRLF & _
"" & @CRLF & _
"[ anychild:parent ]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")