# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"overdraftlog-[0-9]{14}.[0-9]{3}(.log$|.log.sha$)"
test_str = ("overdraft-transactions_2020-06-19_10_20200620020000.csv\n"
"overdraft-transactions_2020-06-19_10_20200620020000.csv.sha1\n"
"overdraft-transactions_2020-06-20_6_20200621020000.csv\n"
"overdraft-transactions_2020-06-20_6_20200621020000.csv.sha1\n"
"overdraft-transactions_2020-06-21_6_20200622020000.csv\n"
"overdraft-transactions_2020-06-21_6_20200622020000.csv.sha1\n"
"overdraft-transactions_2020-06-22_7_20200623020000.csv\n"
"overdraft-transactions_2020-06-22_7_20200623020000.csv.sha1\n"
"overdraft-transactions_2020-06-23_6_20200624020001.csv\n"
"overdraft-transactions_2020-06-23_6_20200624020001.csv.sha1\n"
"overdraft-application_2020-06-19_0_20200620020000.csv\n"
"overdraft-application_2020-06-19_0_20200620020000.csv.sha1\n"
"overdraft-application_2020-06-20_0_20200621020000.csv\n"
"overdraft-application_2020-06-20_0_20200621020000.csv.sha1\n"
"overdraft-application_2020-06-21_0_20200622020000.csv\n"
"overdraft-application_2020-06-21_0_20200622020000.csv.sha1\n"
"overdraft-application_2020-06-22_0_20200623020000.csv\n"
"overdraft-application_2020-06-22_0_20200623020000.csv.sha1\n"
"overdraft-application_2020-06-23_0_20200624020001.csv\n"
"overdraft-application_2020-06-23_0_20200624020001.csv.sha1\n"
"overdraftlog-20201005122521.748.log\n"
"overdraftlog-20201005122521.748.log.sha\n"
"overdraftlog-20201006030000.749.log\n"
"overdraftlog-20201006030000.749.log.sha")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.