import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "overdraftlog-[0-9]{14}.[0-9]{3}(.log$|.log.sha$)";
final String string = "overdraft-transactions_2020-06-19_10_20200620020000.csv\n"
+ "overdraft-transactions_2020-06-19_10_20200620020000.csv.sha1\n"
+ "overdraft-transactions_2020-06-20_6_20200621020000.csv\n"
+ "overdraft-transactions_2020-06-20_6_20200621020000.csv.sha1\n"
+ "overdraft-transactions_2020-06-21_6_20200622020000.csv\n"
+ "overdraft-transactions_2020-06-21_6_20200622020000.csv.sha1\n"
+ "overdraft-transactions_2020-06-22_7_20200623020000.csv\n"
+ "overdraft-transactions_2020-06-22_7_20200623020000.csv.sha1\n"
+ "overdraft-transactions_2020-06-23_6_20200624020001.csv\n"
+ "overdraft-transactions_2020-06-23_6_20200624020001.csv.sha1\n"
+ "overdraft-application_2020-06-19_0_20200620020000.csv\n"
+ "overdraft-application_2020-06-19_0_20200620020000.csv.sha1\n"
+ "overdraft-application_2020-06-20_0_20200621020000.csv\n"
+ "overdraft-application_2020-06-20_0_20200621020000.csv.sha1\n"
+ "overdraft-application_2020-06-21_0_20200622020000.csv\n"
+ "overdraft-application_2020-06-21_0_20200622020000.csv.sha1\n"
+ "overdraft-application_2020-06-22_0_20200623020000.csv\n"
+ "overdraft-application_2020-06-22_0_20200623020000.csv.sha1\n"
+ "overdraft-application_2020-06-23_0_20200624020001.csv\n"
+ "overdraft-application_2020-06-23_0_20200624020001.csv.sha1\n"
+ "overdraftlog-20201005122521.748.log\n"
+ "overdraftlog-20201005122521.748.log.sha\n"
+ "overdraftlog-20201006030000.749.log\n"
+ "overdraftlog-20201006030000.749.log.sha";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}