#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)overdraftlog-[0-9]{14}.[0-9]{3}(.log$|.log.sha$)"
Local $sString = "overdraft-transactions_2020-06-19_10_20200620020000.csv" & @CRLF & _
"overdraft-transactions_2020-06-19_10_20200620020000.csv.sha1" & @CRLF & _
"overdraft-transactions_2020-06-20_6_20200621020000.csv" & @CRLF & _
"overdraft-transactions_2020-06-20_6_20200621020000.csv.sha1" & @CRLF & _
"overdraft-transactions_2020-06-21_6_20200622020000.csv" & @CRLF & _
"overdraft-transactions_2020-06-21_6_20200622020000.csv.sha1" & @CRLF & _
"overdraft-transactions_2020-06-22_7_20200623020000.csv" & @CRLF & _
"overdraft-transactions_2020-06-22_7_20200623020000.csv.sha1" & @CRLF & _
"overdraft-transactions_2020-06-23_6_20200624020001.csv" & @CRLF & _
"overdraft-transactions_2020-06-23_6_20200624020001.csv.sha1" & @CRLF & _
"overdraft-application_2020-06-19_0_20200620020000.csv" & @CRLF & _
"overdraft-application_2020-06-19_0_20200620020000.csv.sha1" & @CRLF & _
"overdraft-application_2020-06-20_0_20200621020000.csv" & @CRLF & _
"overdraft-application_2020-06-20_0_20200621020000.csv.sha1" & @CRLF & _
"overdraft-application_2020-06-21_0_20200622020000.csv" & @CRLF & _
"overdraft-application_2020-06-21_0_20200622020000.csv.sha1" & @CRLF & _
"overdraft-application_2020-06-22_0_20200623020000.csv" & @CRLF & _
"overdraft-application_2020-06-22_0_20200623020000.csv.sha1" & @CRLF & _
"overdraft-application_2020-06-23_0_20200624020001.csv" & @CRLF & _
"overdraft-application_2020-06-23_0_20200624020001.csv.sha1" & @CRLF & _
"overdraftlog-20201005122521.748.log" & @CRLF & _
"overdraftlog-20201005122521.748.log.sha" & @CRLF & _
"overdraftlog-20201006030000.749.log" & @CRLF & _
"overdraftlog-20201006030000.749.log.sha"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")