re = /routing number[:]*\s*(\d{9})(?:[^\d]|$)/im
str = 'routing no. 103000677
routing no 103000677
routing no 304 982 400
routing # 253279471nmls
routing number:231176855
routing number: 101109923lost '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end