#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)routing number[:]*\s*(\d{9})(?:[^\d]|$)"
Local $sString = "routing no. 103000677" & @CRLF & _
"routing no 103000677" & @CRLF & _
"routing no 304 982 400" & @CRLF & _
"routing # 253279471nmls" & @CRLF & _
"routing number:231176855" & @CRLF & _
"routing number: 101109923lost "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")