const regex = /routing number[:]*\s*(\d{9})(?:[^\d]|$)/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('routing number[:]*\\s*(\\d{9})(?:[^\\d]|$)', 'img')
const str = `routing no. 103000677
routing no 103000677
routing no 304 982 400
routing # 253279471nmls
routing number:231176855
routing number: 101109923lost `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}