re = /^[\/\*A-Z0-9_\s]*(?=\{)\{RSTART_(?=(([A-Z0-9]{6}[0-9]))).+(?=(RSTART_(?=(([A-Z0-9]{6}[0-9]))))).+$/m
str = ' {RSTART_IDT1S03, RSTART_IDT1S03},'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end