using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\/\*A-Z0-9_\s]*(?=\{)\{RSTART_(?=(([A-Z0-9]{6}[0-9]))).+(?=(RSTART_(?=(([A-Z0-9]{6}[0-9]))))).+$";
string input = @" {RSTART_IDT1S03, RSTART_IDT1S03},";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}