$re = '/^[\/\*A-Z0-9_\s]*(?=\{)\{RSTART_(?=(([A-Z0-9]{6}[0-9]))).+(?=(RSTART_(?=(([A-Z0-9]{6}[0-9]))))).+$/m';
$str = ' {RSTART_IDT1S03, RSTART_IDT1S03},';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);