// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https://(?P<subdomain>(?:[a-z]+\.)+)?newwheel\.com").unwrap();
let string = "https://newwheel.com
https://itlab.newwheel.com
https://super.sub.domain.newwheel.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}