$re = '/https://(?P<subdomain>(?:[a-z]+\.)+)?newwheel\.com/m';
$str = 'https://newwheel.com
https://itlab.newwheel.com
https://super.sub.domain.newwheel.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);