import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https://(?P<subdomain>(?:[a-z]+\\.)+)?newwheel\\.com";
final String string = "https://newwheel.com\n"
+ "https://itlab.newwheel.com\n"
+ "https://super.sub.domain.newwheel.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}