re = /(?<!\()[A-Z]{2,}(?!\))/m
str = 'If you live in the UK, you need to do X. I you do not live in the United Kingdom (UK), do Y.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end