$re = '/(?<!\()[A-Z]{2,}(?!\))/m';
$str = 'If you live in the UK, you need to do X. I you do not live in the United Kingdom (UK), do Y.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);