const regex = /(?<!\()[A-Z]{2,}(?!\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\()[A-Z]{2,}(?!\\))', 'gm')
const str = `If you live in the UK, you need to do X. I you do not live in the United Kingdom (UK), do Y.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}