use strict;
my $str = 'This is just a post to test regex for extracting URL http://google.com, https://www.youtube.com/watch?v=dlw32af https://instagram.com/oscar/ en.wikipedia.org
Even works for www.wikipedia.de, https://de.wikipedia.org/wiki/Wikipedia:Hauptseite or any other https://en.wikipedia.org/wiki/Regular_expression url. Even comma separated www.url1.com,www.url2.com';
my $regex = qr~\b(?:https?://)?(?:(?i:[a-z]+\.)+)[^\s,]+\b~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}