package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:https?://)?(?:(?i:[a-z]+\.)+)[^\s,]+\b`)
var str = `This is just a post to test regex for extracting URL http://google.com, https://www.youtube.com/watch?v=dlw32af https://instagram.com/oscar/ en.wikipedia.org
Even works for www.wikipedia.de, https://de.wikipedia.org/wiki/Wikipedia:Hauptseite or any other https://en.wikipedia.org/wiki/Regular_expression url. Even comma separated www.url1.com,www.url2.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}