#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:https?://)?(?:(?i:[a-z]+\.)+)[^\s,]+\b"
Local $sString = "This is just a post to test regex for extracting URL http://google.com, https://www.youtube.com/watch?v=dlw32af https://instagram.com/oscar/ en.wikipedia.org" & @CRLF & _
"Even works for www.wikipedia.de, https://de.wikipedia.org/wiki/Wikipedia:Hauptseite or any other https://en.wikipedia.org/wiki/Regular_expression url. Even comma separated www.url1.com,www.url2.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")