re = /^[ЁёА-я]*/m
str = 'Елисей Иванов
Влад Никита
Daladecon .
Nico
Евгений Понасенков
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end