$re = '/^[ЁёА-я]*/m';
$str = 'Елисей Иванов
Влад Никита
Daladecon .
Nico
Евгений Понасенков
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);