package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[ЁёА-я]*`)
var str = `Елисей Иванов
Влад Никита
Daladecon .
Nico
Евгений Понасенков
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}