re = /https?:\/\/(?:www\.)?traveloka\.com\/en-id\/((?!.*activities.*).*)/
str = 'https://www.traveloka.com/en-id/hotel/indonesia/1o1-urban-jakarta-kelapa-gading-461890?spec=25-11-2023.26-11-2023..1.HOTEL.461890..1¤cy=IDR&contexts=%7B%22sourceHotelDetail%22%3A%22HOTEL_POPULAR_WEB%22%7D'
# Print the match result
str.match(re) do |match|
puts match.to_s
end