#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https?:\/\/(?:www\.)?traveloka\.com\/en-id\/((?!.*activities.*).*)"
Local $sString = "https://www.traveloka.com/en-id/hotel/indonesia/1o1-urban-jakarta-kelapa-gading-461890?spec=25-11-2023.26-11-2023..1.HOTEL.461890..1¤cy=IDR&contexts=%7B%22sourceHotelDetail%22%3A%22HOTEL_POPULAR_WEB%22%7D"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")