import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/(?:www\\.)?traveloka\\.com\\/en-id\\/((?!.*activities.*).*)";
final String string = "https://www.traveloka.com/en-id/hotel/indonesia/1o1-urban-jakarta-kelapa-gading-461890?spec=25-11-2023.26-11-2023..1.HOTEL.461890..1¤cy=IDR&contexts=%7B%22sourceHotelDetail%22%3A%22HOTEL_POPULAR_WEB%22%7D";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}