// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\w,]{3,4} (?: (?<jan>Jan )| (?<feb>Feb )| (?<mar>Mar )|(?<apr>Apr )|(?<may>May ) |(?<jun>Jun ) |(?<jul>Jul ) |(?<aug>Aug ) |(?<sep>Sep ) |(?<oct>Oct ) |(?<nov>Nov ) |(?<dec>Dec ))(?<day>\d+) (?<year>\d+) (?<time>\d{1,2}:\d\d:\d\d).*").unwrap();
let string = "Mon, Apr 02 2023 12:34:56 UTC +08:00
Mon May 22 2023 12:34:56 UTC +08:00
Tue ";
let substitution = "${jan:+01/}${feb:+02/}${mar:+03/}${apr:+04/}${may:+05/}${jun:+06/}${jul:+07/}${aug:+08/}${sep:+08/}${oct:+10/}${nov:+11/}${dec:+12/}${day}/${year} ${time}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}