#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[\w,]{3,4} (?: (?<jan>Jan )| (?<feb>Feb )| (?<mar>Mar )|(?<apr>Apr )|(?<may>May ) |(?<jun>Jun ) |(?<jul>Jul ) |(?<aug>Aug ) |(?<sep>Sep ) |(?<oct>Oct ) |(?<nov>Nov ) |(?<dec>Dec ))(?<day>\d+) (?<year>\d+) (?<time>\d{1,2}:\d\d:\d\d).*"
Local $sString = "Mon, Apr 02 2023 12:34:56 UTC +08:00" & @CRLF & _
"Mon May 22 2023 12:34:56 UTC +08:00" & @CRLF & _
"Tue "
Local $sSubst = "${jan:+01/}${feb:+02/}${mar:+03/}${apr:+04/}${may:+05/}${jun:+06/}${jul:+07/}${aug:+08/}${sep:+08/}${oct:+10/}${nov:+11/}${dec:+12/}${day}/${year} ${time}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)