re = /^(?:(?:https?:\/\/)?(?:www\.)?youtu\.?be(?:\.com)?\/)(?:watch\?v=|v\/)?([a-zA-Z0-9_\-]*)/
str = 'https://www.youtube.com/watch?v=Gge6Hg2-RVM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end