import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:https?:\\/\\/)?(?:www\\.)?youtu\\.?be(?:\\.com)?\\/)(?:watch\\?v=|v\\/)?([a-zA-Z0-9_\\-]*)";
final String string = "https://www.youtube.com/watch?v=Gge6Hg2-RVM";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}