package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:(?:https?:\/\/)?(?:www\.)?youtu\.?be(?:\.com)?\/)(?:watch\?v=|v\/)?([a-zA-Z0-9_\-]*)`)
var str = `https://www.youtube.com/watch?v=Gge6Hg2-RVM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}