$re = '/^(W|w|L|l)(7|X|x)([a-zA-Z]{2,4}|[a-zA-Z]{3}it|[a-zA-Z]{3}IT)([0-9]{4})(.fortisbank.com.pl|)$/m';
$str = 'WXKRAIT0005.fortisbank.com.pl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);