#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(W|w|L|l)(7|X|x)([a-zA-Z]{2,4}|[a-zA-Z]{3}it|[a-zA-Z]{3}IT)([0-9]{4})(.fortisbank.com.pl|)$"
Local $sString = "WXKRAIT0005.fortisbank.com.pl"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")