using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(W|w|L|l)(7|X|x)([a-zA-Z]{2,4}|[a-zA-Z]{3}it|[a-zA-Z]{3}IT)([0-9]{4})(.fortisbank.com.pl|)$";
string input = @"WXKRAIT0005.fortisbank.com.pl";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}